summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:43:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:28 +0200
commit5d9aa48bf07ee32c677de64ae2d91a8f7929430a (patch)
tree501087a197e97b995dd1df065abcd2016a925d90 /gnu/packages
parent3adfa442b2d9cf0576632e472cacb54d74722551 (diff)
downloadguix-5d9aa48bf07ee32c677de64ae2d91a8f7929430a.tar.gz
gnu: Add texlive-mnsymbol.
* gnu/packages/tex.scm (texlive-mnsymbol): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f79af0bed5..758bc5172c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18818,6 +18818,38 @@ accented letters using ordinary Computer Modern (CM) fonts.  The system is
 distributed as a TeX change file.")
     (license license:knuth)))
 
+(define-public texlive-mnsymbol
+  (package
+    (name "texlive-mnsymbol")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mnsymbol/"
+                   "fonts/enc/dvips/mnsymbol/"
+                   "fonts/map/dvips/mnsymbol/"
+                   "fonts/map/vtex/mnsymbol/"
+                   "fonts/opentype/public/mnsymbol/"
+                   "fonts/source/public/mnsymbol/"
+                   "fonts/tfm/public/mnsymbol/"
+                   "fonts/type1/public/mnsymbol/"
+                   "source/latex/mnsymbol/"
+                   "tex/latex/mnsymbol/")
+             (base32
+              "164zspl0wcpmba9j0kl6wy8k46xaafjvwjp0dn82dzh73r85jdk2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/mnsymbol")
+    (synopsis "Mathematical symbol font for Adobe MinionPro")
+    (description
+     "MnSymbol is a symbol font family, designed to be used in conjunction
+with Adobe Minion Pro (via the MinionPro package).  Almost all of LaTeX and
+AMS mathematical symbols are provided; remaining coverage is available from
+the MinionPro font with the MinionPro package.  The fonts are available both
+as Metafont source and as Adobe Type 1 format, and a comprehensive support
+package is provided.")
+    (license license:public-domain)))
+
 (define-public texlive-multibib
   (package
     (name "texlive-multibib")