summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-05 00:15:57 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-05 22:09:36 -0500
commit5dcbd9accfcf0e97579604f57681c0565ae07ec2 (patch)
treea9b1a5bfa9723fd7b34100fd067f5dc532e60809 /gnu/packages
parent7e214b9a1aab3e00de6e71f3700021092d179862 (diff)
downloadguix-5dcbd9accfcf0e97579604f57681c0565ae07ec2.tar.gz
gnu: libx11: Ungraft.
* gnu/packages/xorg.scm (libx11): Update to 1.8.7.
[replacement]: Remove.
[source]: Update URL.
(libx11-fixed): Remove variable.

Change-Id: I945c5d15ca7ef3ed9f5de348815f9644028b1c9a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xorg.scm22
1 files changed, 4 insertions, 18 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f65ffa7476..4039f8675a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5332,16 +5332,15 @@ Wayland.")
 (define-public libx11
   (package
     (name "libx11")
-    (version "1.8.1")
-    (replacement libx11-fixed)          ;security fixes
+    (version "1.8.7")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://xorg.freedesktop.org/archive/"
-                           "/individual/lib/libX11-" version ".tar.xz"))
+       (uri (string-append "mirror://xorg/individual/lib/libX11-"
+                           version ".tar.xz"))
        (sha256
         (base32
-         "1xyry8i7zqmlkvpbyyqwi18rrdw6ycczlvfp63rh2570pfhimi0v"))))
+         "1vlrgrdibp4lr84wgmsdy1ihzaai8bvvqc68npi1m19wir36gwh5"))))
     (build-system gnu-build-system)
     (outputs '("out"
                "doc"))                  ;8 MiB of man pages + XML
@@ -5363,19 +5362,6 @@ Wayland.")
     (description "Xorg Core X11 protocol client library.")
     (license license:x11)))
 
-(define-public libx11-fixed
-  (package
-    (inherit libx11)
-    (version "1.8.7")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://xorg/individual/lib/libX11-"
-                           version ".tar.xz"))
-       (sha256
-        (base32
-         "1vlrgrdibp4lr84wgmsdy1ihzaai8bvvqc68npi1m19wir36gwh5"))))))
-
 ;; packages of height 5 in the propagated-inputs tree
 
 (define-public libxcursor