summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:07 +0200
commit5e6b27f66151ec6d4712969ef6e8b09a20ffdfad (patch)
tree332a89e4c2653a1b7016746d1e5a3a5943e6c7eb /gnu/packages
parent7045f0a3b80abed8a706ca0714674986c0b82d05 (diff)
downloadguix-5e6b27f66151ec6d4712969ef6e8b09a20ffdfad.tar.gz
gnu: Add texlive-showcharinbox.
* gnu/packages/tex.scm (texlive-showcharinbox): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d68f10d0cf..c4b58263e4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95507,6 +95507,26 @@ variant commands also display the internal macros used by such commands, if
 any.  The @code{\\showcs} variant helps with macros with exotic names.")
     (license license:lppl)))
 
+(define-public texlive-showcharinbox
+  (package
+    (name "texlive-showcharinbox")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/showcharinbox/"
+                   "source/latex/showcharinbox/"
+                   "tex/latex/showcharinbox/")
+             (base32
+              "1y91l00r6a04bjvqxqf0s4k3bf093q2wccd6s7dcz78wbp92ycj9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/showcharinbox")
+    (synopsis "Show characters inside a box")
+    (description
+     "The package typesets a character inside a box, showing where reference point
+is, and displaying width, height, and depth information of the character.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar