summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-01 16:38:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:35:48 +0300
commit610803c04ee9c7f71820d9b4f4feaabdf609cc30 (patch)
tree25000c00435a84df3ab779c58ee12d4967601394 /gnu/packages
parent047e84ae9569795310854176627e9cd389a1f69e (diff)
downloadguix-610803c04ee9c7f71820d9b4f4feaabdf609cc30.tar.gz
gnu: Add rust-rctree-0.5.
* gnu/packages/crates-io.scm (rust-rctree-0.5): New variable.
(rust-rctree-0.4): Inherit from rust-rctree-0.5.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 20 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c599eda1d8..eaf5b72891 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53894,8 +53894,27 @@ Rust.")
         ("rust-webpki" ,rust-webpki-0.22)
         ("rust-x509-parser" ,rust-x509-parser-0.12))))))
 
+(define-public rust-rctree-0.5
+  (package
+    (name "rust-rctree")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rctree" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0kvzahkwriawhjjb08ai7rfi77px7rpx5h83hjcx6dccyxzf4hiv"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/RazrFalcon/rctree")
+    (synopsis "DOM-like tree implemented using reference counting")
+    (description "This package provides a @code{DOM-like} tree implemented using
+reference counting.")
+    (license license:expat)))
+
 (define-public rust-rctree-0.4
   (package
+    (inherit rust-rctree-0.5)
     (name "rust-rctree")
     (version "0.4.0")
     (source
@@ -53905,13 +53924,7 @@ Rust.")
         (file-name (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "1s92472lniqn2c0b5ln8ssl014x0raiyzkk0hagrvsd6far2iq4s"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/RazrFalcon/rctree")
-    (synopsis "DOM-like tree implemented using reference counting")
-    (description "This package provides a @code{DOM-like} tree implemented using
-reference counting.")
-    (license license:expat)))
+          "1s92472lniqn2c0b5ln8ssl014x0raiyzkk0hagrvsd6far2iq4s"))))))
 
 (define-public rust-rdrand-0.4
   (package