summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-15 23:15:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:53:56 +0200
commit62cfb4915970e90d2379456ac1d0581ffbf04b76 (patch)
treefa149c2edd6531abc007471182e433331087f910 /gnu/packages
parent03baf02e6f2ad81cc30b25762d702a343a775f2c (diff)
downloadguix-62cfb4915970e90d2379456ac1d0581ffbf04b76.tar.gz
gnu: Add go-github-com-surge-glog.
* gnu/packages/golang.scm (go-github-com-surge-glog): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 03863529c7..e207a57aa5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3623,3 +3623,27 @@ to use.")
 physical system memory accessible to the kernel.  It does not account for memory
 used by other processes.")
       (license license:bsd-3))))
+
+(define-public go-github-com-surge-glog
+  (let ((commit "2578deb2b95c665e6b1ebabf304ce2085c9e1985")
+        (revision "1"))
+    (package
+      (name "go-github-com-surge-glog")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/surge/glog")
+                       (commit commit)))
+                (file-name (string-append "go-github-com-surge-glog-"
+                                          version "-checkout"))
+                (sha256
+                 (base32
+                  "1bxcwxvsvr2hfpjz9hrrn0wrgykwmrbyk567102k3vafw9xdcwk4"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/surge/glog"))
+      (home-page "https://github.com/surge/glog")
+      (synopsis "Leveled execution logs for Go")
+      (description "Leveled execution logs for Go.")
+      (license license:asl2.0))))