summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-10-15 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-10-15 02:00:00 +0200
commit62d42bdd75cafbbf80c722d792a325eb51ba20af (patch)
treec5f87f8ada561a5c6edcfad8026572d2522f5bb8 /gnu/packages
parent12ddeaad785a728137ecccc9ac9ecc78fdd5e1da (diff)
downloadguix-62d42bdd75cafbbf80c722d792a325eb51ba20af.tar.gz
gnu: font-terminus: Install the README.
* gnu/packages/fonts.scm (font-terminus): Add a new
'install-documentation phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fonts.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a529f325a2..4254408e0f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -580,6 +580,10 @@ The unified Libertinus family consists of:
     (outputs (list "out" "pcf-8bit" "otb"))
     (arguments
      `(#:tests? #f                      ; no test target in tarball
+       #:modules
+       ((guix build gnu-build-system)
+        (guix build utils)
+        (ice-9 match))
        #:phases
        (modify-phases %standard-phases
          (add-after 'build 'build-more-bits
@@ -601,7 +605,16 @@ The unified Libertinus family consists of:
            (lambda* (#:key make-flags outputs #:allow-other-keys)
              (let ((otb (assoc-ref outputs "otb")))
                (apply invoke "make" "install-otb" (string-append "prefix=" otb)
-                      make-flags)))))))
+                      make-flags))))
+         (add-after 'install 'install-documentation
+           ;; There's no way to decypher the cryptic file names without this.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (for-each (match-lambda
+                         ((name . directory)
+                          (install-file "README"
+                                        (string-append directory "/share/doc/"
+                                                       ,name "-" ,version))))
+                       outputs))))))
     (native-inputs
      (list bdftopcf font-util mkfontdir pkg-config python))
     (home-page "https://terminus-font.sourceforge.net/")