summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-31 12:01:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-31 13:15:25 -0400
commit6318e7a85159495e41f3730037a30c9f90b28b43 (patch)
treeb363756abafe40e176eaf5c2f22d90c9b1c59513 /gnu/packages
parent5e5547d1b39668ea4b0fa050db4eede038c4a699 (diff)
downloadguix-6318e7a85159495e41f3730037a30c9f90b28b43.tar.gz
gnu: python-spectral-cube: Update to 0.6.3.
* gnu/packages/astronomy.scm (python-spectral-cube): Update to 0.6.3.
[native-inputs]: Add python-setuptools-scm.

Change-Id: I8b701081d2c8ea2fd8f25ca845e8e26760fdc094
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2b0ff97f68..185383fd33 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2535,13 +2535,13 @@ elevation, solar azimuth, rahukaalam, and the phases of the moon.")
 (define-public python-spectral-cube
   (package
     (name "python-spectral-cube")
-    (version "0.6.2")
+    (version "0.6.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "spectral-cube" version))
        (sha256
-        (base32 "1xyqdflnz084hdx1pbrqd1jrfyyc7f8v3564rww2v1hjylzgsnnh"))))
+        (base32 "10q76rsgf9w4j7y68mfa870bpxf06m6kqvivj4340jmgnsrfy1zg"))))
     (build-system pyproject-build-system)
     (propagated-inputs
      (list python-astropy
@@ -2566,7 +2566,8 @@ elevation, solar azimuth, rahukaalam, and the phases of the moon.")
            ;; python-pvextractor
            python-pytest-astropy
            python-regions
-           python-semantic-version))
+           python-semantic-version
+           python-setuptools-scm))
     (home-page "https://spectral-cube.readthedocs.io/en/latest/")
     (synopsis "Library for reading and analyzing astrophysical spectral data cubes")
     (description