summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 16:52:59 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:08:38 +0200
commit6500c9a5b364616e38a7e03aa4516fc2d7cee876 (patch)
tree23b5eefef9bdc843f52dfd8bb35a354b5473adab /gnu/packages
parent58f6927af56b7fdf1fd9b5506b276f45f265be10 (diff)
downloadguix-6500c9a5b364616e38a7e03aa4516fc2d7cee876.tar.gz
gnu: nss-certs: Do not inherit version and source from nss.
...in order to avoid a top-level variable reference.  This reverts commit
18c38c18989aab28a654c9e546243603690cc75e.

* gnu/packages/certs.scm (nss-certs)[version, source]: Do not inherit from NSS.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/certs.scm14
-rw-r--r--gnu/packages/nss.scm4
2 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 60fa8cec29..82e5b8c987 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -71,8 +71,18 @@ that was originally contributed to Debian.")
 (define-public nss-certs
   (package
     (name "nss-certs")
-    (version (package-version nss))
-    (source (package-source nss))
+    (version "3.67")
+    (source (origin
+              (method url-fetch)
+              (uri (let ((version-with-underscores
+                          (string-join (string-split version #\.) "_")))
+                     (string-append
+                      "https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
+                      "releases/NSS_" version-with-underscores "_RTM/src/"
+                      "nss-" version ".tar.gz")))
+              (sha256
+               (base32
+                "0zyfi27lbdz1bmk9dmsivcya4phx25rzlxqcnjab69yd928rlm7n"))))
     (build-system gnu-build-system)
     (outputs '("out"))
     (native-inputs
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 2b6bdf323a..55eddc0c91 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -71,8 +71,8 @@ platform-neutral API for system level and libc-like functions.  It is used
 in the Mozilla clients.")
     (license license:mpl2.0)))
 
-;;; Note: When updating, also test the build of the nss-certs package, which
-;;; uses the same source as nss.
+;;; Note: When updating, also update the nss-certs package, which cannot
+;;; inherit from here.
 (define-public nss
   (package
     (name "nss")