summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 08:43:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:14 +0200
commit674e93a057ecc79a4f670e48b45d8e910f4f69a3 (patch)
treea9a515b361efab71a8c8f032759d1e4a4b7019c8 /gnu/packages
parent37e2e5d43401da93eebd21c08d1b6a73b9982b13 (diff)
downloadguix-674e93a057ecc79a4f670e48b45d8e910f4f69a3.tar.gz
gnu: Add java-eclipse-osgi.
* gnu/packages/java.scm (java-eclipse-osgi): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/java.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d5b2d61bde..3d8dd06a02 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2343,6 +2343,31 @@ and service platform for the Java programming language.  This package contains
 the OSGi Core module.")
     (license license:asl2.0)))
 
+(define-public java-eclipse-osgi
+  (package
+    (name "java-eclipse-osgi")
+    (version "3.11.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "org/eclipse/platform/org.eclipse.osgi/"
+                                  version "/org.eclipse.osgi-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "00cqc6lb29n0zv68b4l842vzkwawvbr7gshfdygsk8sicvcq2c7b"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests included
+       #:jar-name "eclipse-equinox-osgi.jar"))
+    (inputs
+     `(("java-osgi-annotation" ,java-osgi-annotation)))
+    (home-page "http://www.eclipse.org/equinox/")
+    (synopsis "Eclipse Equinox OSGi framework")
+    (description "This package provides an implementation of the OSGi Core
+specification.")
+    (license license:epl1.0)))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")