summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-08 22:24:21 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-08 22:24:21 +0100
commit677078b48f649588f588c6adef0bb0aba70f7c8c (patch)
tree93ecd602c188236b7b6b29e86c0740410b2050f4 /gnu/packages
parenta3eb919fb4621b94d56522a661b6564d391196e8 (diff)
downloadguix-677078b48f649588f588c6adef0bb0aba70f7c8c.tar.gz
gnu: Add perl-net-http.
* gnu/packages/web.scm (perl-net-http): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d9821d87ec..390ace8f69 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -320,3 +320,25 @@ fields in the request.")
 /robots.txt file to forbid conforming robots from accessing parts of
 their web site.")
     (home-page "http://search.cpan.org/~gaas/WWW-RobotRules/")))
+
+(define-public perl-net-http
+  (package
+    (name "perl-net-http")
+    (version "6.06")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "mirror://cpan/authors/id/G/GA/GAAS/Net-HTTP-"
+                   version ".tar.gz"))
+             (sha256
+              (base32
+               "1m1rvniffadq99gsy25298ia3lixwymr6kan64jd3ylyi7nkqkhx"))))
+    (build-system perl-build-system)
+    (license (package-license perl))
+    (synopsis "Perl low-level HTTP connection (client)")
+    (description
+     "The Net::HTTP class is a low-level HTTP client.  An instance of the
+Net::HTTP class represents a connection to an HTTP server.  The HTTP protocol
+is described in RFC 2616.  The Net::HTTP class supports HTTP/1.0 and
+HTTP/1.1.")
+    (home-page "http://search.cpan.org/~gaas/Net-HTTP/")))