summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-12 14:49:49 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:39 +0800
commit67b16f40023d665a0da6bcf2605d1d1b917c07ea (patch)
tree2bf863db3c96b604ed880bb0f537afe33d027c3b /gnu/packages
parentf7f3d98e2d14382461360d1cae081dd916df7f06 (diff)
downloadguix-67b16f40023d665a0da6bcf2605d1d1b917c07ea.tar.gz
gnu: kconfigwidgets: Update to 5.108.0.
* gnu/packages/kde-frameworks.scm (kconfigwidgets): Update to 5.108.0.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 95daa7e934..9dc532a183 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2246,7 +2246,7 @@ KCModules can be created with the KConfigWidgets framework.")
 (define-public kconfigwidgets
   (package
     (name "kconfigwidgets")
-    (version "5.98.0")
+    (version "5.108.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -2255,7 +2255,7 @@ KCModules can be created with the KConfigWidgets framework.")
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "05bwldqc5k6dlzsxjby5565sch6i0mh7jg5cbyjz24xb1fpj0d7b"))))
+                "1raz1bxra0dvcwwzvhfmz1y0hvfrffpdymd116xyi5lnavyzdp46"))))
     (build-system qt-build-system)
     (propagated-inputs
      (list kauth kcodecs kconfig kwidgetsaddons))
@@ -2276,12 +2276,11 @@ KCModules can be created with the KConfigWidgets framework.")
              (substitute* "src/khelpclient.cpp"
                ;; make QDirIterator follow symlinks
                (("^\\s*(QDirIterator it\\(.*, QDirIterator::Subdirectories)(\\);)" _ a b)
-                (string-append a " | QDirIterator::FollowSymlinks" b)))
-             (substitute* "CMakeLists.txt"
-               (("5\\.90\\.0") "5.98.0"))))
+                (string-append a " | QDirIterator::FollowSymlinks" b)))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
+               (setenv "HOME" (getcwd))
                (invoke "ctest" "-E" "kstandardactiontest")))))))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Widgets for configuration dialogs")