summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:47:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:29 +0200
commit6ab9d6a404c0db1c3f097b006430fbecdb1a720a (patch)
tree963a990df56f817f9143c030afe0a3595a44375f /gnu/packages
parent79ef8cec5a441510cbd00867e1dad9397dabb248 (diff)
downloadguix-6ab9d6a404c0db1c3f097b006430fbecdb1a720a.tar.gz
gnu: Add texlive-qtree.
* gnu/packages/tex.scm (texlive-qtree): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 16cafab383..642e6b3d87 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10930,6 +10930,28 @@ commands, and then issue the @code{\\tree} command to typeset the whole.")
 a domain-specific language for quantum programming.")
     (license license:lppl1.3c)))
 
+(define-public texlive-qtree
+  (package
+    (name "texlive-qtree")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/qtree/" "tex/latex/qtree/")
+             (base32
+              "1gmwkm6400pcrjnq111bih7za0p45nx6gy4lksvgjhdcpnykbbla")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/qtree")
+    (synopsis "Draw tree structures")
+    (description
+     "The package offers support for drawing tree diagrams, and is especially
+suitable for linguistics use.  It allows trees to be specified in a simple
+bracket notation, automatically calculates branch sizes, and supports both
+DVI/PostScript and PDF output by use of @code{pict2e} facilities.  The package
+is a development of the existing @code{qobitree} package, offering a new front
+end.")
+    (license license:lppl)))
+
 (define-public texlive-rank-2-roots
   (package
     (name "texlive-rank-2-roots")