summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-12-14 21:26:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-12-14 21:59:39 +0100
commit6b7877e12c264af34915eb8a12bbb520f8b6af47 (patch)
tree58e4ee7c1252002b86ffa3a07aa0adfc119eb745 /gnu/packages
parentddf1cd519c7aea90e18accbbb62dd008390f713a (diff)
downloadguix-6b7877e12c264af34915eb8a12bbb520f8b6af47.tar.gz
gnu: python-mock: Update source and home-page URIs.
* gnu/packages/python.scm (python-mock)[source]: Use ‘pypi-uri’.
[home-page]: Replace dead Google Code home page.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 826720ccd5..789e199f51 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -797,14 +797,13 @@ API for locking files.")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://pypi.python.org/packages/source/m/mock/"
-                           "mock-" version ".tar.gz"))
+       (uri (pypi-uri "mock" version))
        (sha256
         (base32
          "0kzlsbki6q0awf89rc287f3aj8x431lrajf160a70z0ikhnxsfdq"))))
     (build-system python-build-system)
     (arguments '(#:test-target "check"))
-    (home-page "http://code.google.com/p/mock/")
+    (home-page "https://github.com/testing-cabal/mock")
     (synopsis "Python mocking and patching library for testing")
     (description
      "Mock is a library for testing in Python.  It allows you to replace parts