summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-26 16:08:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-26 17:04:17 +0200
commit6ce76bdc313f8c71c2e016aa1e279e27c139ee42 (patch)
treed05cd9cd16f6ca0e4e674b9599697dfc0d228f16 /gnu/packages
parent80746f97f148d58c012b8479fca3eac3ced67de6 (diff)
downloadguix-6ce76bdc313f8c71c2e016aa1e279e27c139ee42.tar.gz
gnu: whois: Update to 5.3.1.
* gnu/packages/networking.scm (whois): Update to 5.3.1.
[inputs]: Change from LIBIDN to LIBIDN2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9793620e14..a95f5d10e0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -500,7 +500,7 @@ and up to 1 Mbit/s downstream.")
 (define-public whois
   (package
     (name "whois")
-    (version "5.3.0")
+    (version "5.3.1")
     (source
      (origin
        (method url-fetch)
@@ -508,7 +508,7 @@ and up to 1 Mbit/s downstream.")
                            name "_" version ".tar.xz"))
        (sha256
         (base32
-         "08sp2gzv09rar1a5mnfmbc24pqvhpqqmz2hnmv436n7v7d09qy2d"))))
+         "0gl98l26dcgmlap0pxllbv4b9n2fr5b7zml3ijf8sf3a60qsskpg"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no test suite
@@ -522,8 +522,7 @@ and up to 1 Mbit/s downstream.")
              (setenv "HAVE_ICONV" "1")
              #t)))))
     (inputs
-     ;; TODO: Switch to libidn2 when >= 2.0.3 is ungrafted in master.
-     `(("libidn" ,libidn)))
+     `(("libidn2" ,libidn2)))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("perl" ,perl)