summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 08:42:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:14 +0200
commit6ee6d0b58a022d2a659304496e9a304d1b20663e (patch)
treebe894da3bffc8e8c3c2c36b8435968a82f7002d5 /gnu/packages
parent77d7b57cdcc22a4ab6fc4b52e2edfeb974954f57 (diff)
downloadguix-6ee6d0b58a022d2a659304496e9a304d1b20663e.tar.gz
gnu: Add java-osgi-annotation.
* gnu/packages/java.scm (java-osgi-annotation): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/java.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 1f26ef67ad..26d251f138 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2292,6 +2292,31 @@ many basic Internet protocols.  The purpose of the library is to provide
 fundamental protocol access, not higher-level abstractions.")
     (license license:asl2.0)))
 
+(define-public java-osgi-annotation
+  (package
+    (name "java-osgi-annotation")
+    (version "6.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "org/osgi/org.osgi.annotation/" version "/"
+                                  "org.osgi.annotation-" version "-sources.jar"))
+              (sha256
+               (base32
+                "1q718mb7gqg726rh6pc2hcisn8v50nv35abbir0jypmffhiii85w"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:jar-name "osgi-annotation.jar"))
+    (home-page "http://www.osgi.org")
+    (synopsis "Annotation module of OSGi framework")
+    (description
+     "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language.  This package contains
+the OSGi annotation module, providing additional services to help dynamic
+components.")
+    (license license:asl2.0)))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")