summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-02-06 22:25:18 -0500
committerMark H Weaver <mhw@netris.org>2017-02-06 22:25:18 -0500
commit6f48d9db10231857f523f1cb467ee903fd956fcb (patch)
treef3bf6cdc226158964c73e54afb82187bf7d0c360 /gnu/packages
parenta062b6ca99ad61c9df473fe49a93d69f9698c59d (diff)
downloadguix-6f48d9db10231857f523f1cb467ee903fd956fcb.tar.gz
gnu: epiphany: Update to 3.22.6 [security update].
See <https://bugzilla.gnome.org/show_bug.cgi?id=752738>.

* gnu/packages/gnome.scm (epiphany): Update to 3.22.6.
[arguments]: Add #:configure-flags '("CFLAGS=-std=gnu99").
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f6f7aae696..cd115f1f0c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3634,7 +3634,7 @@ work and the interface is well tested.")
 (define-public epiphany
   (package
     (name "epiphany")
-    (version "3.22.4")
+    (version "3.22.6")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -3642,7 +3642,7 @@ work and the interface is well tested.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0skdsma9rmq01703andigmpbdn2rl34y3lqny19a93v1ph3jb9qk"))))
+                "1hpwjwiviwh9dgc9cwq0gmr5jy40rvigjcq0cbg2nw2hqiyshzny"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      ;; FIXME: tests run under Xvfb, but fail with:
@@ -3650,7 +3650,8 @@ work and the interface is well tested.")
      ;;   ** (test-ephy-bookmarks:19591): WARNING **: Unable to start Zeroconf
      ;;      subsystem
      ;;   FAIL
-     '(#:tests? #f))
+     '(#:tests? #f
+       #:configure-flags '("CFLAGS=-std=gnu99")))
     (propagated-inputs
      `(("dconf" ,dconf)))
     (native-inputs