summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-17 19:49:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-22 21:48:28 +0000
commit6f6cfb8365e3ef44de5b9f022331c31d84778dea (patch)
tree7df57d78cb1bdd667fbd87f4f40ba73d936893ec /gnu/packages
parentffc5fefce370f5fc01091869e13fdf525be1e0c0 (diff)
downloadguix-6f6cfb8365e3ef44de5b9f022331c31d84778dea.tar.gz
gnu: python-tdda: Remove relax-requirements phase.
* gnu/packages/python-science.scm (python-tdda)[arguments]<#:phases>: Remove relax-requirements phase.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-science.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c1be6cde23..ef65ed537a 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -22,7 +22,7 @@
 ;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
-;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -376,11 +376,6 @@ implements several methods for sequential model-based optimization.
     (build-system pyproject-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'relax-requirements
-                    (lambda _
-                      (substitute* "setup.py"
-                        (("pandas>=1.5.2")
-                         "pandas"))))
                   (replace 'check
                     (lambda* (#:key tests? #:allow-other-keys)
                       (when tests?