summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2023-05-01 18:18:42 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-05 23:59:52 +0200
commit71a438dcba391022fbbc41a1703f3172bae9c63c (patch)
tree3e0d5caac427b3f245ca012ae768c299bd2a9a07 /gnu/packages
parentecb27103531ece0ee302957ff04cab8a17ec1ab3 (diff)
downloadguix-71a438dcba391022fbbc41a1703f3172bae9c63c.tar.gz
gnu: git-crypt: Fix build issues on OpenSSL 3.
* gnu/packages/version-control.scm (git-crypt)[arguments]: In 'build'
phase, set 'CXXFLAGS'.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4fbf3b4d05..4bdf63cc63 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -937,6 +937,10 @@ write native speed custom Git applications in any language with bindings.")
              #t))
          (replace 'build
            (lambda _
+             ;; Add flag to work around OpenSSL 3 incompatibility.
+             ;; See <https://github.com/AGWA/git-crypt/issues/232>.
+             (setenv "CXXFLAGS" "-DOPENSSL_API_COMPAT=0x30000000L")
+
              (invoke "make" "ENABLE_MAN=yes")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)