summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-11 21:29:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:32:24 -0400
commit72abf72062f0e813efb633e05b42c99c4bc78cff (patch)
tree7d9118a9fe5ac3fe720a8d0e7863292e9e3de367 /gnu/packages
parent0993236a95b12a4e51827ba52a08783bb01486cb (diff)
downloadguix-72abf72062f0e813efb633e05b42c99c4bc78cff.tar.gz
gnu: Remove qtquickcontrols2.
* gnu/packages/qt.scm (qtquickcontrols2): Delete variable.
(pyotherside) [inputs]: Remove qtquickcontrols2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/qt.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index eda92b103e..5132d8553a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2206,12 +2206,6 @@ module that provides platform integration: native dialogs, menus and menu bars,
 and tray icons.  It falls back to Qt Widgets when a native implementation is
 not available.")))
 
-(define-public qtquickcontrols2
-  ;; qtquickcontrols2 still exist, but was merged into qtdeclarative.
-  ;; Unfortunately that hasn't been well communicated at all (see:
-  ;; https://bugreports.qt.io/browse/QTBUG-79454).
-  (deprecated-package "qtquickcontrols2" qtdeclarative))
-
 (define-public qtgraphicaleffects
   (package
     (inherit qtsvg-5)
@@ -3445,7 +3439,7 @@ instances.")
             ;; installation prefix.
             (lambda _
               (invoke "make" "sub-src-install_subtargets"))))))
-    (inputs (list python qtdeclarative qtquickcontrols2 qtsvg))
+    (inputs (list python qtdeclarative qtsvg))
     (home-page "https://thp.io/2011/pyotherside/")
     (synopsis "Qt plugin providing access to a Python 3 interpreter from QML")
     (description "Pyotherside is a Qt plugin providing access to a Python 3