summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-05-02 19:41:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-05-02 20:02:20 +0200
commit73124d34227a7df8a5319c5497f62c6323a64800 (patch)
treef21a9c81e02b8f7a477aade86b7c9beec7265e7f /gnu/packages
parent6855b34754e5560040717922bdbc810547e2cc79 (diff)
downloadguix-73124d34227a7df8a5319c5497f62c6323a64800.tar.gz
gnu: bristol: Do not check for JACK with ldd.
* gnu/packages/music.scm (bristol)[arguments]: Add build phase to
  disable runtime check for JACK.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 8465954dc7..4946024264 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -831,6 +831,13 @@ mixing, FFT scopes, MIDI automation and full scriptability in Scheme.")
                             (string-prefix? "i686" system)))
                (substitute* "bristol/Makefile.in"
                  (("-msse -mfpmath=sse") "")))
+             #t))
+         ;; We know that Bristol has been linked with JACK and we don't have
+         ;; ldd, so we can just skip this check.
+         (add-after 'unpack 'do-not-grep-for-jack
+           (lambda _
+             (substitute* "bin/startBristol.in"
+               (("ldd `which bristol` | grep jack") "echo guix"))
              #t)))))
     (inputs
      `(("alsa-lib" ,alsa-lib)