summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:22 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:04 +0000
commit744bfc61da8464d8f07210318a797e51456a4f5e (patch)
tree03d0ff94f43b456f295ddd7c6b790a737b0bbc40 /gnu/packages
parent1f7cf5834cdf8349a26c99c280e9514487526350 (diff)
downloadguix-744bfc61da8464d8f07210318a797e51456a4f5e.tar.gz
gnu: gdk-pixbuf: Use target predicates.
This seems a little tidier to me.

* gnu/packages/gtk.scm (gdk-pixbuf)[arguments]<#:phases>{check}: Use
  target-arm? instead of string=?.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index bbef514dd7..691e207165 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -643,8 +643,7 @@ highlighting and other features typical of a source code editor.")
                 ""))
              #t))
          ;; The slow tests take longer than the specified timeout.
-         ,@(if (any (cute string=? <> (%current-system))
-                    '("armhf-linux" "aarch64-linux"))
+         ,@(if (target-arm? (%current-system))
                '((replace 'check
                    (lambda* (#:key tests? #:allow-other-keys)
                      (when tests?