summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-05-10 09:12:41 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-05-10 09:56:10 -0400
commit7455ed8e520b6a3853b1495a4ae19553bf1e8813 (patch)
tree42e69c6b0ff5181324cfccb9111842de7765f604 /gnu/packages
parent956ca540dc8d2e2fc10f0202cd78ecba5edd21f0 (diff)
downloadguix-7455ed8e520b6a3853b1495a4ae19553bf1e8813.tar.gz
gnu: Add ruby-cbor.
* gnu/packages/ruby.scm (ruby-cbor): New variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ffc7ad3bec..75f31a3101 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12442,3 +12442,28 @@ reference object.  This object is not created until the first method dispatch.")
     (description "Citrus is a parsing library for Ruby that combines the
 expressiveness of the language with the parsing expressions.")
     (license license:expat)))
+
+(define-public ruby-cbor
+  (package
+    (name "ruby-cbor")
+    (version "0.5.9.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "cbor" version))
+        (sha256
+          (base32 "0511idr8xps9625nh3kxr68sdy6l3xy2kcz7r57g47fxb1v18jj3"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:test-target "spec"))
+    (native-inputs
+     (list
+      ruby-rspec
+      ruby-rake-compiler
+      ruby-yard))
+    (home-page "http://cbor.io/")
+    (synopsis "Concise Binary Object Representation")
+    (description "CBOR is a library for the
+@acronym{CBOR, Concise Binary Object Representation} format, based on
+Sadayuki Furuhashi's MessagePack library.")
+    (license license:asl2.0)))