summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-02 21:07:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:04 +0200
commit74f90a09aab39784e84acf03b0169060a4317bc2 (patch)
treece1d2ebf86719fa2c9936189263210738694df2e /gnu/packages
parent1e16eed2e4194e5ddd59b91c474a7335288194b4 (diff)
downloadguix-74f90a09aab39784e84acf03b0169060a4317bc2.tar.gz
gnu: rust-rustix-0.38: Update to 0.38.28.
* gnu/packages/crates-io.scm (rust-rustix-0.38): Update to 0.38.28.
[cargo-inputs]: Replace rust-windows-sys-0.48 with 0.52.

Change-Id: Ida9f8a027eae0dd1356c2a73b58fa2c7dcfb0d0c
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3cc399a766..8b5339994c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -61002,31 +61002,30 @@ rustc compiler.")
 (define-public rust-rustix-0.38
   (package
     (name "rust-rustix")
-    (version "0.38.15")
+    (version "0.38.28")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "rustix" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0cg5jsfx8lf5npjf2v5ac8fca5443hq8iqqlg2gg1yc8pl6dmyfj"))
+        (base32 "05m3vacvbqbg6r6ksmx9k5afpi0lppjdv712crrpsrfax2jp5rbj"))
        (snippet
-               #~(begin
-                   (use-modules (guix build utils))
-                   (for-each delete-file (find-files "." "\\.a$"))
-                   (delete-file "Cargo.toml")
-                   (substitute* "Cargo.toml.orig"
-                     ;; Depend unconditionally on the cc crate
-                     (("(cc = .*), optional = true.*" _ cc)
-                      (string-append cc " }\n"))
-                     ;; Disable using the linux_raw backend
-                     (("not\\(rustic_use_libc\\)") "miri"))
-                   (substitute* "build.rs"
-                     ;; Always use the 'feature = "cc"' path
-                     (("not\\(feature = \"cc\"\\)") "feature = \"foobar\"")
-                     (("#\\[cfg\\(feature = \"cc\"\\)\\]" all)
-                      (string-append "//" all)))
-                   (copy-file "Cargo.toml.orig" "Cargo.toml")))))
+        #~(begin (use-modules (guix build utils))
+                 (for-each delete-file (find-files "." "\\.a$"))
+                 (delete-file "Cargo.toml")
+                 (substitute* "Cargo.toml.orig"
+                   ;; Depend unconditionally on the cc crate
+                   (("(cc = .*), optional = true.*" _ cc)
+                    (string-append cc " }\n"))
+                   ;; Disable using the linux_raw backend
+                   (("not\\(rustic_use_libc\\)") "miri"))
+                 (substitute* "build.rs"
+                   ;; Always use the 'feature = "cc"' path
+                   (("not\\(feature = \"cc\"\\)") "feature = \"foobar\"")
+                   (("#\\[cfg\\(feature = \"cc\"\\)\\]" all)
+                    (string-append "//" all)))
+                 (copy-file "Cargo.toml.orig" "Cargo.toml")))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -61039,7 +61038,7 @@ rustc compiler.")
         ("rust-once-cell" ,rust-once-cell-1)
         ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
         ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
-        ("rust-windows-sys" ,rust-windows-sys-0.48))
+        ("rust-windows-sys" ,rust-windows-sys-0.52))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.4)
         ("rust-ctor" ,rust-ctor-0.2)