summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-07-27 16:31:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:23 +0200
commit7717577b0a49a16b42756f51ae803e84810325d3 (patch)
tree49e64e592345bc2f6ab3b55c893285da452970fc /gnu/packages
parent0b744fda53269d9d7ca94d42647bfc53ce3012ad (diff)
downloadguix-7717577b0a49a16b42756f51ae803e84810325d3.tar.gz
gnu: Add rust-wee-alloc-0.4.
* gnu/packages/crates-io.scm (rust-wee-alloc-0.4): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Change-Id: Id732b8209165490c7e964b1f97022ffdf0b75df0
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6a50317cf1..81eef5e88e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -85863,6 +85863,30 @@ implementation of webview, a tiny cross-platform library to render web-based
 GUIs as desktop applications.")
     (license license:expat)))
 
+(define-public rust-wee-alloc-0.4
+  (package
+    (name "rust-wee-alloc")
+    (version "0.4.5")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "wee_alloc" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "13hb19nfqwjwcqlfj46sjz4j49wd7sj6hbjasimcn5xvnakbbcyv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-0.1)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-memory-units" ,rust-memory-units-0.4)
+                       ("rust-spin" ,rust-spin-0.5)
+                       ("rust-winapi" ,rust-winapi-0.3))))
+    (home-page "https://github.com/rustwasm/wee_alloc")
+    (synopsis "wee_alloc: The Wasm-Enabled, Elfin Allocator")
+    (description "wee_alloc: The Wasm-Enabled, Elfin Allocator")
+    (license license:mpl2.0)))
+
 (define-public rust-weezl-0.1
   (package
     (name "rust-weezl")