summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-01-29 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-02-12 01:00:00 +0100
commit77aff2b5d201a68542684aefb1fcf83b4d17490a (patch)
treec32bb45fc246effedacb16cb44b2489eb7254494 /gnu/packages
parent016eab3e29263045b1422289b7ec9382edc725f9 (diff)
downloadguix-77aff2b5d201a68542684aefb1fcf83b4d17490a.tar.gz
gnu: papirus-icon-theme: Harden links before cache generation.
Output is identical.  This just feels moar correct.

* gnu/packages/gnome-xyz.scm (papirus-icon-theme)[arguments]: Run the
'halve-inode-consumption phase before the 'install one.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome-xyz.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index e1d0e5ec07..f25cf446d7 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -217,21 +217,20 @@ simple and consistent.")
          (delete 'bootstrap)
          (delete 'configure)
          (delete 'build)
-         (add-after 'install 'halve-inode-consumption
+         (add-before 'install 'halve-inode-consumption
            ;; This package uses over 100K inodes, which is a lot.  We can easily
            ;; halve that number by using (hard) links, to no ill effect.
            ;; See <https://logs.guix.gnu.org/guix/2023-01-31.log#171227>.
            ;; However, the source checkout will still use the full amount!
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (symlink? (lambda (_ stat)
+           (lambda _
+             (let ((symlink? (lambda (_ stat)
                                (eq? 'symlink (stat:type stat)))))
                (for-each (lambda (file)
                            (let ((target (canonicalize-path file)))
                              (when (eq? 'regular (stat:type (stat target)))
                                (delete-file file)
                                (link target file))))
-                         (find-files out symlink?))))))))
+                         (find-files "." symlink?))))))))
     (native-inputs
      (list `(,gtk+ "bin")))
     (home-page "https://git.io/papirus-icon-theme")