summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-13 21:20:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-14 21:29:27 +0100
commit77c5d63f4d76f2905d975316347948cc913c6d20 (patch)
tree949b676cf758ab596de4e78732fa8f768884490c /gnu/packages
parent568004c3c9a87b95d4e19a3187f336a20d33440a (diff)
downloadguix-77c5d63f4d76f2905d975316347948cc913c6d20.tar.gz
gnu: libidn2: Create 'pkg-config' file.
* gnu/packages/libidn.scm (libidn2)[arguments]: Add phase creating libidn2.pc.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/libidn.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/libidn.scm b/gnu/packages/libidn.scm
index 3af19b1c70..df0ac8b0b4 100644
--- a/gnu/packages/libidn.scm
+++ b/gnu/packages/libidn.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -60,9 +61,34 @@ Java libraries.")
               (sha256
                (base32
                 "13v8kh4d5nfkymai88zlw3h7k4x9khrpdpv97waf4ah8ykzrxb9g"))))
+    ;; XXX: Make sure to remove the 'create-pkg-config' phase
+    ;; below when this package is updated to >= 0.17.
     (inputs
      `(("libunistring" ,libunistring)))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'create-pkgconfig-file
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (pkgconfig (string-append out "/lib/pkgconfig")))
+               (mkdir-p pkgconfig)
+               (call-with-output-file (string-append pkgconfig "/libidn2.pc")
+                 (lambda (port)
+                   (format port "prefix=~a
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: Libidn2
+Description: Library implementing IDNA2008 and TR46
+Version: ~a
+Libs: -L${libdir} -lidn2
+Cflags: -I${includedir}
+"
+                           out ,version)))
+               #t))))))
     (synopsis "Internationalized domain name library for IDNA2008")
     (description "Libidn2 is an internationalized domain library implementing
 the IDNA2008 specifications.   Libidn2 is believed to be a complete IDNA2008