summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:02 +0200
commit77e562d933d809d1f5328e7c3d361d3402be2529 (patch)
tree4f46eec1bcf9ca9a2c262c0ed5450032eb813484 /gnu/packages
parent766d2ea06d6cfac19ca567c8d820604e3d5f05cf (diff)
downloadguix-77e562d933d809d1f5328e7c3d361d3402be2529.tar.gz
gnu: Add texlive-topiclongtable.
* gnu/packages/tex.scm (texlive-topiclongtable): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b8f19fa40f..8b89013a43 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98462,6 +98462,29 @@ concatenated macro names; macros for text replacement.")
     (description "This package moves floats to the top of the page.")
     (license license:gpl3+)))
 
+(define-public texlive-topiclongtable
+  (package
+    (name "texlive-topiclongtable")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/topiclongtable/"
+                   "tex/latex/topiclongtable/")
+             (base32
+              "0ib9d3an7glqgc329f5krjjqf5cdwrpdzfv2b9sl6hpfyw0z7r7f")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/topiclongtable")
+    (synopsis "Extend longtable with cells that merge hierarchically")
+    (description
+     "This LaTeX package extends @code{longtable} implementing cells that: merge
+with the one above if it has the same content, do not merge with the one above
+unless the ones on the left are merged, are well behaved with respect to
+@code{longtable} chunking on page breaks, and automatically draw the correct
+separation lines.  The typical use case is a table spanning multiple pages
+that contains a list of hierarchically organized topics.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar