summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-12-20 16:09:54 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-19 17:54:49 +0100
commit7a36e8e21809d05fdd011a0ce2ce7a83127c6679 (patch)
treeb21dc945df616fc872742d11973ae36e2bbcb319 /gnu/packages
parent8803cb9eb9b78779ea440f21a7c65b0a62572ee3 (diff)
downloadguix-7a36e8e21809d05fdd011a0ce2ce7a83127c6679.tar.gz
gnu: python-eventlet: Manage broken tests with nosetests.
* gnu/packages/python-xyz.scm (python-eventlet):
  [arguments] Manage broken tests with nosetests.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86ccc00bf7..acc6c051e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2876,15 +2876,14 @@ standard.")
              ;; getprotobyname is called.  Thankfully there is an environment
              ;; variable to disable the greendns import, so use it:
              (setenv "EVENTLET_NO_GREENDNS" "yes")))
-         (add-after 'unpack 'delete-broken-tests
-           (lambda _
-             (delete-file "tests/greendns_test.py")
-             (delete-file "tests/socket_test.py")))
-         ;; See https://github.com/eventlet/eventlet/issues/562#issuecomment-714183009
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "nosetests" "-v" "tests/")))))))
+               (invoke
+                "nosetests"
+                "-v" "tests/"
+                "-I" "greendns_test.py"
+                "-I" "socket_test.py")))))))
     (home-page "https://eventlet.net")
     (synopsis "Concurrent networking library for Python")
     (description