summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-23 17:53:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:36 +0300
commit7b0767fb64747f36c75b0ef732301859a0a69df8 (patch)
tree3927d457a768ea8b09ae70034c842f02108fb344 /gnu/packages
parent1b8cf9a1286d5a3b7c99a1cc978c9fcc643f4a6b (diff)
downloadguix-7b0767fb64747f36c75b0ef732301859a0a69df8.tar.gz
gnu: Add rust-x11-clipboard-0.7.
* gnu/packages/crates-graphics.scm (rust-x11-clipboard-0.7): New variable.
(rust-x11-clipboard-0.5): Inherit from rust-x11-clipboard-0.7.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-graphics.scm28
1 files changed, 22 insertions, 6 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index afd8337bbe..a587c11b3a 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -3609,8 +3609,29 @@ the platform-specific getters provided by winit, or another library.")
     (description "This package provides Rust bindings to X11")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-x11-clipboard-0.7
+  (package
+    (name "rust-x11-clipboard")
+    (version "0.7.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "x11-clipboard" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0r3lgslbbdf0mb914n0f9q2pqci407r1pcddwbl7sfvc4alrl2wq"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f      ; Wants a running X server.
+       #:cargo-inputs (("rust-x11rb" ,rust-x11rb-0.10))))
+    (home-page "https://github.com/quininer/x11-clipboard")
+    (synopsis "x11 clipboard support for Rust")
+    (description "This package provides x11 clipboard support for Rust.")
+    (license license:expat)))
+
 (define-public rust-x11-clipboard-0.5
   (package
+    (inherit rust-x11-clipboard-0.7)
     (name "rust-x11-clipboard")
     (version "0.5.1")
     (source
@@ -3620,15 +3641,10 @@ the platform-specific getters provided by winit, or another library.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "17c5yxxhknrp7y9mc7mp85ra8q4jw12c174m9yzbfr1vs2pkgsg5"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
-       (("rust-xcb" ,rust-xcb-0.9))))
-    (home-page "https://github.com/quininer/x11-clipboard")
-    (synopsis "x11 clipboard support for Rust")
-    (description "This package provides x11 clipboard support for Rust.")
-    (license license:expat)))
+       (("rust-xcb" ,rust-xcb-0.9))))))
 
 (define-public rust-x11-dl-2
   (package