summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2023-08-09 22:37:16 -0400
committerLudovic Courtès <ludo@gnu.org>2023-08-12 22:36:36 +0200
commit7b11cfd19e9cae1b8308fae974307168c1766723 (patch)
tree4e51f74b035dfad894df4e9696840046dd9975a6 /gnu/packages
parent6bbef3d9a269c38a6af941fb8f7c7b1d82834776 (diff)
downloadguix-7b11cfd19e9cae1b8308fae974307168c1766723.tar.gz
gnu: uwufetch: Add and use missing inputs.
* gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs.
[phases]: Use the fully-qualified paths of the input gawk and grep.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 33f9b703a7..6b6b05c4a0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4025,6 +4025,11 @@ you are running, what theme or icon set you are using, etc.")
           (delete 'configure)
           (add-before 'build 'patch-source-paths
             (lambda _
+              (substitute* "fetch.c"
+                (("grep")
+                 #$(file-append grep "/bin/grep"))
+                (("awk")
+                 #$(file-append gawk "/bin/awk")))
               (substitute* "uwufetch.c"
                 (("(/usr(/local)?)(.*;)" all _ _ rest)
                  (string-append #$output rest)))))
@@ -4033,6 +4038,8 @@ you are running, what theme or icon set you are using, etc.")
             (lambda _
               (mkdir-p (string-append #$output "/include")))))))
     (inputs (list lshw
+                  gawk
+                  grep
                   ;; viu XXX not yet packaged in Guix
                   xwininfo))
     (home-page "https://github.com/TheDarkBug/uwufetch")