summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:14 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:03 +0000
commit7b71cd6dab0b44e03e38e32111e01d2e9d32ef99 (patch)
tree4d71f323834f5ecf6ec8bf1262fc83188d32440e /gnu/packages
parent9bf44750dc54718ca4b121a4c7539dde49cf37da (diff)
downloadguix-7b71cd6dab0b44e03e38e32111e01d2e9d32ef99.tar.gz
gnu: gobject-introspection: Move things to native-inputs.
* gnu/packages/glib.scm (gobject-introspection)[native-inputs]: Make
  'bison' and 'flex' inputs unconditional ...
  (gobject-introspection)[inputs]: ... and unconditionally remove them here.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/glib.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bdcc108ac1..cbaece6cf1 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -486,18 +486,12 @@ be used when cross-compiling."
     (native-inputs
      `(("glib" ,glib "bin")
        ("pkg-config" ,pkg-config)
-       ;; TODO(core-updates): Unconditionally place "flex" and "bison"
-       ;; in 'native-inputs'.
-       ,@(if (%current-target-system)
-             `(("bison" ,bison)
-               ("flex" ,flex))
-             '())))
+       ("bison" ,bison)
+       ("flex" ,flex)))
     (inputs
      `(,@(if (%current-target-system)
              `(("python" ,python))
-             `(("bison" ,bison)
-               ("flex" ,flex)
-               ("python" ,python-wrapper)))
+             `(("python" ,python-wrapper)))
        ("zlib" ,zlib)))
     (propagated-inputs
      `(("glib" ,glib)