summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-05 20:17:50 -0500
committerLeo Famulari <leo@famulari.name>2017-03-05 20:19:18 -0500
commit7bc19c92054b7b6d5a9268a7f2d3344adf04cce4 (patch)
tree960e2a9ef5a0d43ab8c92efc4b73fc0b14bcee72 /gnu/packages
parent33c93ea33ed9ab35f9432665f931285898ca75c7 (diff)
downloadguix-7bc19c92054b7b6d5a9268a7f2d3344adf04cce4.tar.gz
gnu: xmlto: Fix source URL.
Works around <https://bugs.gnu.org/25989>.

* gnu/packages/xml.scm (xmlto)[source]: Update URL.
[file-name]: New field.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xml.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 6ec2b1fdc9..66eb63ade4 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -849,9 +849,11 @@ code for classes that correspond to data structures defined by XMLSchema.")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append
-            "https://fedorahosted.org/releases/x/m/xmlto/xmlto-"
-            version ".tar.bz2"))
+      ;; The old source on fedorahosted.org is offline permanently:
+      ;; <https://bugs.gnu.org/25989>
+      (uri (string-append "mirror://debian/pool/main/x/xmlto/"
+                          "xmlto_" version ".orig.tar.bz2"))
+      (file-name (string-append name "-" version ".tar.bz2"))
       (sha256
        (base32
         "0xhj8b2pwp4vhl9y16v3dpxpsakkflfamr191mprzsspg4xdyc0i"))))