summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-08 22:37:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:42 -0400
commit7cf6b7e21a25fe77975d34c4f2fdbdaabecacd5b (patch)
tree80cb8abe3bd0ad140fbee24bc88f000703d0bfea /gnu/packages
parented26f1cf439174e22663c9dc3e66b48e78c0c021 (diff)
downloadguix-7cf6b7e21a25fe77975d34c4f2fdbdaabecacd5b.tar.gz
gnu: python-liblarch: Update to 3.2.0 and apply guix style.
* gnu/packages/gnome.scm (python-liblarch): Update to 3.2.0; apply guix style.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 19 insertions, 24 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0ff63e9134..e4049bc70f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2721,32 +2721,27 @@ schemas for settings shared by various components of the GNOME desktop.")
 (define-public python-liblarch
   (package
     (name "python-liblarch")
-    (version "3.0.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/getting-things-gnome/liblarch")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0xv2mfvyzipbny3iz8vll77wsqxfwh28xj6bj1ff0l452waph45m"))))
+    (version "3.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/getting-things-gnome/liblarch")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "125rmrdbc84lapfh8c77zxnmwas20xdfamqmilhv1smkxn2q4sh3"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'start-xserver
-           (lambda* (#:key inputs #:allow-other-keys)
-             (system (format #f "~a/bin/Xvfb :1 &"
-                             (assoc-ref inputs "xorg-server")))
-             (setenv "DISPLAY" ":1")
-             #t)))))
-    (native-inputs
-     (list xorg-server-for-tests))
-    (inputs
-     (list gtk+))
-    (propagated-inputs
-     (list python-pygobject))
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'start-xserver
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (system (format #f "~a/bin/Xvfb :1 &"
+                                      (assoc-ref inputs "xorg-server")))
+                      (setenv "DISPLAY" ":1"))))))
+    (native-inputs (list xorg-server-for-tests))
+    (inputs (list gtk+))
+    (propagated-inputs (list python-pygobject))
     (home-page "https://wiki.gnome.org/Projects/liblarch")
     (synopsis "Library to easily handle complex data structures")
     (description