summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 10:43:31 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:05 +0100
commit7d6e8fda61fa5c198d044ababe9f567ba1f8414e (patch)
tree98efdc813b9c65cf574642d64f0c7b122485fcd6 /gnu/packages
parent9bc96d13ce726ef91603459dfb023d65418ad7ad (diff)
downloadguix-7d6e8fda61fa5c198d044ababe9f567ba1f8414e.tar.gz
gnu: sedsed: Don't use unstable tarball.
* gnu/packages/admin.scm (sedsed)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2b60e9136a..2381efac94 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2303,16 +2303,16 @@ in order to be able to find it.
     (version "1.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/aureliojargas/sedsed/"
-                           "archive/v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aureliojargas/sedsed.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0139jkqvm8ipiwfj7k69ry2f9b1ffgpk79arpz4r7w9kf6h23bnh"))))
+        (base32 "0009lsjsxhqmgaklpwq15hhd94hpiy7r4va69yy0ig3mxi6zbg2z"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ; No tests.
+     `(#:tests? #f                      ; no tests
        #:python ,python-2
        #:phases
        (modify-phases %standard-phases