summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 11:59:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:34 +0200
commit7f71c9701e2323948cd369a9992b9c6db17a115f (patch)
treec386f9ef82a4937c97287778f59c4395771f0037 /gnu/packages
parent0f9de640d38c6e9f59e7bf53c4f0920cc9304ee2 (diff)
downloadguix-7f71c9701e2323948cd369a9992b9c6db17a115f.tar.gz
gnu: Add texlive-chembst.
* gnu/packages/tex.scm (texlive-chembst): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cf987dcfbb..6062211a4d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5847,6 +5847,30 @@ in the font are designed to look more like those in chemistry text-books than
 do Knuth's originals.")
     (license license:public-domain)))
 
+(define-public texlive-chembst
+  (package
+    (name "texlive-chembst")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/chembst/" "doc/latex/chembst/"
+                   "source/latex/chembst/")
+             (base32
+              "026j8lv3kbxmbq6sc1n8rdrr47njgn5mn9im1mmppzk5bi7w6yzz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/chembst")
+    (synopsis "Collection of BibTeX files for chemistry journals")
+    (description
+     "The package offers a collection of advanced BibTeX style files suitable
+for publications in chemistry journals.  Currently, style files for journals
+published by the American Chemical Society, Wiley-VCH and The Royal Society of
+Chemistry are available.  The style files support advanced features such as
+automatic formatting of errata or creating an appropriate entry for
+publications in @emph{Angewandte Chemie} where both English and German should
+be cited simultaneously.")
+    (license license:lppl)))
+
 (define-public texlive-chemcompounds
   (package
     (name "texlive-chemcompounds")