summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 19:27:06 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:24 +0000
commit821fa7bd4389c1f830d6d83564107a242db03129 (patch)
tree50e9cce65b7bec4af5612954e6e88dd646815256 /gnu/packages
parentef67f851a0349b339f42f61ed7664c5ef3cfbb3c (diff)
downloadguix-821fa7bd4389c1f830d6d83564107a242db03129.tar.gz
gnu: gnome-clocks: Update to 40.0.
* gnu/packages/gnome.scm (gnome-clocks): Update to 40.0.
[source]: Fix the URI.
[arguments]: Remove a trailing #t.
[inputs]: Add libhandy.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 02af01bf5d..f8a0e266e1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9578,15 +9578,15 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
 (define-public gnome-clocks
   (package
     (name "gnome-clocks")
-    (version "3.34.0")
+    (version "40.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version) "/"
+                                  (version-major version) "/"
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0g7hjk55smhkd09hwa9kag3h5a12l494wj89w9smpdk3ghsmy6b1"))))
+                "02d3jg46sn8d9gd4dsaly22gg5vkbz2gpq4pmwpvncb4rsqk7sn2"))))
     (build-system meson-build-system)
     (arguments
      '(#:glib-or-gtk? #t
@@ -9596,8 +9596,7 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
            ;; Don't create 'icon-theme.cache'.
            (lambda _
              (substitute* "build-aux/post-install.py"
-               (("gtk-update-icon-cache") "true"))
-             #t)))))
+               (("gtk-update-icon-cache") "true")))))))
     (native-inputs
      `(("vala" ,vala)
        ("pkg-config" ,pkg-config)
@@ -9612,6 +9611,7 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
        ("geoclue" ,geoclue)
        ("geocode-glib" ,geocode-glib)
        ("libgweather" ,libgweather)
+       ("libhandy" ,libhandy)
        ("gnome-desktop" ,gnome-desktop)))
     (home-page "https://wiki.gnome.org/Apps/Clocks")
     (synopsis "GNOME's clock application")