summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-08-11 13:22:32 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-12 23:13:04 +0200
commit83861b64e6ba66f4612e452f629704dbde0e267f (patch)
treed1d19660a377aeccc303b96da3694554efa030dc /gnu/packages
parent0069db9154c164d757a2969af5f2dabbb979daae (diff)
downloadguix-83861b64e6ba66f4612e452f629704dbde0e267f.tar.gz
gnu: Add cage.
* gnu/packages/wm.scm (cage): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8cc1f43e38..ae571965e6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -63,6 +63,7 @@
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2023 Vessel Wave <vesselwave@disroot.org>
+;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -193,6 +194,27 @@
 the leaves of a full binary tree.")
     (license license:bsd-2)))
 
+(define-public cage
+  (package
+    (name "cage")
+    (version "0.1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cage-kiosk/cage")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256 (base32 "11sg9x08zl2nr7a723h462knz5lf58sgvkhv1mgc9z3hhkhvbsja"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config scdoc))
+    (inputs (list wayland wlroots libxkbcommon))
+    (home-page "https://github.com/cage-kiosk/cage")
+    (synopsis "Wayland kiosk")
+    (description "This package provides a Wayland @dfn{kiosk}, which runs a
+single, maximized application.")
+    (license license:expat)))
+
 (define-public herbstluftwm
   (package
     (name "herbstluftwm")