summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-08 15:50:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-08 20:05:06 +0200
commit850b3b116a8231ced1633d349f91a7da614ca101 (patch)
treefc6423861d352cd7ff0fe6834417bea5dd0a3d6b /gnu/packages
parent626d9215589a4c8606b7b6141434094846850d7d (diff)
downloadguix-850b3b116a8231ced1633d349f91a7da614ca101.tar.gz
gnu: liblinphone: Update to 5.2.50.
* gnu/packages/linphone.scm (liblinphone): Update to 5.2.50.
[arguments]: Use G-expression; disable flexiapi and strict mode.
[inputs]: Replace openldap with openldap-for-linphone; add zxing-cpp.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linphone.scm58
1 files changed, 31 insertions, 27 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 29fcb66074..3beb8c7ab8 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -23,6 +23,7 @@
 (define-module (gnu packages linphone)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
+  #:use-module (gnu packages aidc)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages cpp)
@@ -744,7 +745,7 @@ device.")
 (define-public liblinphone
   (package
     (name "liblinphone")
-    (version "4.4.34")
+    (version "5.2.50")
     (source
      (origin
        (method git-fetch)
@@ -753,30 +754,32 @@ device.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1lwabr93jw24y04pdqnw9dgg8jb3lzfplyx19f83jgp9dj8kmfq9"))))
+        (base32 "1lvbva234rmck57cxgswgqqvnq8r58i0ls4qgpymrxdfj74rinxj"))))
     (outputs '("out" "tester"))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f                      ; Tests require networking
-       #:configure-flags (list "-DENABLE_STATIC=NO"
-                               "-DENABLE_DOC=NO" ;requires unpackaged javasphinx
-                               "-DENABLE_LDAP=YES")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'separate-outputs
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (tester (assoc-ref outputs "tester"))
-                    (tester-name (string-append ,name "_tester")))
-               (for-each mkdir-p
-                         (list (string-append tester "/bin")
-                               (string-append tester "/share")))
-               (rename-file (string-append out "/bin/" tester-name)
-                            (string-append tester "/bin/" tester-name))
-               (rename-file (string-append out "/bin/groupchat_benchmark")
-                            (string-append tester "/bin/groupchat_benchmark"))
-               (rename-file (string-append out "/share/" tester-name)
-                            (string-append tester "/share/" tester-name))))))))
+     (list
+      #:tests? #f                       ; Tests require networking
+      #:configure-flags
+      '(list "-DENABLE_FLEXIAPI=NO"  ;requires jsoncpp, but it cannot be found
+             "-DENABLE_STATIC=NO"
+             "-DENABLE_DOC=NO"       ;requires unpackaged javasphinx
+             "-DENABLE_LDAP=YES"
+             "-DENABLE_STRICT=NO")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'separate-outputs
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((tester-name (string-append #$name "_tester")))
+                (for-each mkdir-p
+                          (list (string-append #$output:tester "/bin")
+                                (string-append #$output:tester "/share")))
+                (rename-file (string-append #$output "/bin/" tester-name)
+                             (string-append #$output:tester "/bin/" tester-name))
+                (rename-file (string-append #$output "/bin/groupchat_benchmark")
+                             (string-append #$output:tester "/bin/groupchat_benchmark"))
+                (rename-file (string-append #$output "/share/" tester-name)
+                             (string-append #$output:tester "/share/" tester-name))))))))
     (native-inputs
      (list graphviz
            doxygen
@@ -792,16 +795,17 @@ device.")
            belle-sip
            belr
            bzrtp
-           openldap
-           xsd
            lime
-           mediastreamer2
            libnotify
+           libxml2
+           mediastreamer2
+           openldap-for-linphone
            ortp
            soci
            sqlite
-           libxml2
-           zlib))
+           xsd
+           zlib
+           zxing-cpp))
     (synopsis "Belledonne Communications Softphone Library")
     (description "Liblinphone is a high-level SIP library integrating
 all calling and instant messaging features into an unified