summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:58 +0200
commit85400ef86c0ccbfa8b6f21836d9b8d89c8573ce9 (patch)
tree4c1f2bf132fb583c5dbe52ac8762d43144ec4e9e /gnu/packages
parent92abd893adfb68b61aba3d58742e5f8f479996e8 (diff)
downloadguix-85400ef86c0ccbfa8b6f21836d9b8d89c8573ce9.tar.gz
gnu: Add texlive-titlepic.
* gnu/packages/tex.scm (texlive-titlepic): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fb580fefc0..baa328b97e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98261,6 +98261,25 @@ footnotes to the title or first page of a document.  It works with any class
 for which the @code{\\thanks} macro works (e.g., @code{article}).")
     (license license:lppl)))
 
+(define-public texlive-titlepic
+  (package
+    (name "texlive-titlepic")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/titlepic/" "tex/latex/titlepic/")
+             (base32
+              "1mqmcqyh7c109m158n38mv0jhxlppdb92ki2g38g9y9gaq6jbr49")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/titlepic")
+    (synopsis "Add picture to title page of a document")
+    (description
+     "The package allows you to place a picture on the title page (cover page) of
+a LaTeX document.  The package currently only works with the document classes
+@code{article}, @code{report} and @code{book}.")
+    (license license:public-domain)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar