summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:47 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:20 +0000
commit8595b82d5536f4b18ce9a78142ee02fd7dd8fd4a (patch)
tree4049f93546941ab1b6e18b0db5d81172384f321d /gnu/packages
parentcf842e9b20b89ecb08ac3456a91780ec07b5a201 (diff)
downloadguix-8595b82d5536f4b18ce9a78142ee02fd7dd8fd4a.tar.gz
gnu: Add go-github-com-a8m-envsubst.
* gnu/packages/golang-xyz.scm (go-github-com-a8m-envsubst): New
variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I356924d0eb4137425608d64d7ed16e1430b9be03
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 50beb0dffe..5312198009 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
@@ -50,6 +51,29 @@
 ;;;
 ;;; Code:
 
+(define-public go-github-com-a8m-envsubst
+  (package
+    (name "go-github-com-a8m-envsubst")
+    (version "1.4.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/a8m/envsubst")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1mjs729g9nmalx25l4nn3p07amm4vsciqmdf0jbh2jwpy1zymz41"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/a8m/envsubst"))
+    (home-page "https://github.com/a8m/envsubst")
+    (synopsis "Environment variables substitution for Go")
+    (description
+     "This package provides a library for environment variables
+substitution.")
+    (license license:expat)))
+
 (define-public go-github-com-anmitsu-go-shlex
   (package
     (name "go-github-com-anmitsu-go-shlex")