summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-27 19:48:21 +0800
committerLudovic Courtès <ludo@gnu.org>2020-07-13 12:52:53 +0200
commit85d9f9bae696ba3e773f408d76a4028d0fb0d4b4 (patch)
tree5755763148265298f6de849f803e652cbeebd037 /gnu/packages
parent565bf214ad0258c66eef22c48e13c902a77ac439 (diff)
downloadguix-85d9f9bae696ba3e773f408d76a4028d0fb0d4b4.tar.gz
gnu: Add r-binman.
* gnu/packages/cran.scm (r-binman): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 60a99d1664..6e196635e0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22422,3 +22422,34 @@ operating on semantic version strings.  Semantic versioning is a simple set of
 rules and requirements that dictate how version numbers are assigned and
 incremented as outlined at @url{http://semver.org}.")
     (license license:expat)))
+
+(define-public r-binman
+  (package
+    (name "r-binman")
+    (version "0.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "binman" version))
+        (sha256
+          (base32
+            "0hm0h285p4v9lhrqjy8s22f1s1vmfpfla5iaycpj8vw3qb3632az"))))
+    (properties `((upstream-name . "binman")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-assertthat" ,r-assertthat)
+        ("r-httr" ,r-httr)
+        ("r-jsonlite" ,r-jsonlite)
+        ("r-rappdirs" ,r-rappdirs)
+        ("r-semver" ,r-semver)
+        ("r-xml2" ,r-xml2)
+        ("r-yaml" ,r-yaml)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/ropensci/binman")
+    (synopsis "Binary download manager")
+    (description
+      "This package provides tools and functions for managing the download of
+binary files.  Binary repositories are defined in the YAML format.  Defining
+new pre-download, download and post-download templates allow additional
+repositories to be added.")
+    (license license:expat)))