summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-14 17:14:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-14 17:15:23 +0200
commit863bd265e458d2761906770802716555c54e69a4 (patch)
tree79d195ca5bceb27c55d0a1a1fefba763fe4d2152 /gnu/packages
parent9fd8f44bd7524399651ba677e93b5e4d36f8e524 (diff)
downloadguix-863bd265e458d2761906770802716555c54e69a4.tar.gz
gnu: python-stevedore: Propagate pbr.
* gnu/packages/openstack.scm (python-stevedore)[native-inputs]: Move
python-pbr from here...
[propagated-inputs]: ...to here.
[arguments]: Add phase to patch requirements.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/openstack.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 26b275e0fd..1e3ad1057a 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -307,8 +307,15 @@ to docs.openstack.org and developer.openstack.org.")
     (arguments
      ;; The tests are disabled to avoid a circular dependency with
      ;; python-stestr.
-     `(#:tests? #f))
-    (native-inputs
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'use-pbr-3
+           (lambda _
+             (substitute* '("setup.py"
+                            "requirements.txt")
+               (("pbr!=2.1.0,>=2.0.0") "pbr>=3.0.0")))))))
+    (propagated-inputs
      `(("python-pbr" ,python-pbr)))
     (home-page "https://github.com/dreamhost/stevedore")
     (synopsis "Manage dynamic plugins for Python applications")