summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2024-02-08 21:06:09 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-08 21:46:22 +0000
commit870f604aa6bc998ba1dc1a086306eaba07b2ec72 (patch)
tree7475287a053636c2d9e0862319058f53c4fc58b9 /gnu/packages
parent98f8a2a34e36b806d85129207243d4c939081ef5 (diff)
downloadguix-870f604aa6bc998ba1dc1a086306eaba07b2ec72.tar.gz
gnu: Add go-github-com-nats-io-nuid.
* gnu/packages/golang-xyz.scm (go-github-com-nats-io-nuid): New variable.

Change-Id: I71ef84703b6971cabacafcba09d1447544fb48bf
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b7c6cec1c2..bfe9cee5e6 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -144,6 +144,29 @@ Differentiation between text and binary files}.
     (description "This package provides an idiomatic Go retry module.")
     (license license:expat)))
 
+(define-public go-github-com-nats-io-nuid
+  (package
+    (name "go-github-com-nats-io-nuid")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nats-io/nuid")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11zbhg4kds5idsya04bwz4plj0mmiigypzppzih731ppbk2ms1zg"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/nats-io/nuid"))
+    (home-page "https://github.com/nats-io/nuid")
+    (synopsis "Go library implementing identifier generator for NATS ecosystem")
+    (description
+     "This package provides a unique identifier generator that is high performance,
+very fast, and tries to be entropy pool friendly.")
+    (license license:asl2.0)))
+
 (define-public go-go-uber-org-automaxprocs
   (package
     (name "go-go-uber-org-automaxprocs")