summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-02-07 15:19:30 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-02-22 16:12:22 +0100
commit8a8540496f66684e5ba0c27fa139237cb8c50ddb (patch)
treed2b69f6830b9f1376859dfa31e3c82e34301fcb0 /gnu/packages
parent8726461dca901ce8bda5b692be53f56864cc9039 (diff)
downloadguix-8a8540496f66684e5ba0c27fa139237cb8c50ddb.tar.gz
gnu: Add tagainijisho.
* gnu/packages/education.scm (tagainijisho): New variable.

Change-Id: I85834c9e91a743540ef751e0c2bb3138b4c3b762
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/education.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index c3009537e9..698f15678b 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1163,3 +1163,37 @@ mentored learning for programming languages.")
     (description "Mazo is a learning application that helps you memorize
 simple concepts using multimedia flash cards and spaced reviews.")
     (license license:public-domain)))
+
+(define-public tagainijisho
+  (package
+    (name "tagainijisho")
+    (version "1.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/Gnurou/tagainijisho/releases/download/"
+             version
+             "/tagainijisho-" version ".tar.gz"))
+       (sha256
+        (base32
+         "00whfcnpn42asxmafcfbcmpwfwyv40qaqdk28psa1vp0lainmyhh"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:tests? #f))                ;no test target
+    (native-inputs
+     (list qttools-5))
+    (synopsis "Japanese dictionary and learning assistant")
+    (description
+     "Tagaini Jisho is a Japanese dictionary and kanji lookup tool.  It aims
+at becoming your Japanese study assistant.  It allows you to quickly search
+for entries and mark those that you wish to study, along with tags and
+personal notes.  It also let you train entries you are studying and follows
+your progression in remembering them.  Finally, it makes it easy to review
+entries you did not remember by listing them on screen or printing them on
+a small booklet.
+
+Tagaini Jisho also features complete stroke order animations for more than
+6000 kanji.")
+    (home-page "https://www.tagaini.net")
+    (license license:gpl3+)))