summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 23:54:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:29 +0200
commit8b495d5f775106b3c5630862bcb5801273e35fee (patch)
tree68c9fd4a6fd501846dc4cb402e5818c1538684ae /gnu/packages
parentefe1112548dae8efb0dd4b23241790955138ee1b (diff)
downloadguix-8b495d5f775106b3c5630862bcb5801273e35fee.tar.gz
gnu: Add texlive-ctan-chk.
* gnu/packages/tex.scm (texlive-ctan-chk): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3cc8c0880d..87d947514d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1459,6 +1459,26 @@ the processing.  Note that the validation is the default and an official
 submission has to be requested by an appropriate command line option.")
     (license license:bsd-3)))
 
+(define-public texlive-ctan-chk
+  (package
+    (name "texlive-ctan-chk")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/support/ctan_chk/")
+             (base32
+              "09ngqgs08q8bld334jrzhnd558lv7fajfppmfrkp4kv9hc5iyz9a")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ctan_chk")
+    (synopsis "CTAN guidelines verifier and corrector for uploading projects")
+    (description
+     "@code{ctan_chk} is a basic Gawk program that uses CTAN's published
+guidelines for authors to help eliminate sloppiness in uploaded
+files/projects.  It is completely open for users to program additional
+guidelines as well as CTAN's future adjustments.")
+    (license license:gpl3)))
+
 (define-public texlive-dvipsconfig
   (package
     (name "texlive-dvipsconfig")