summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-09-19 23:27:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-19 23:28:03 +0200
commit8c56ab99d93c2d37fcc08d3fcff44c64b12ed443 (patch)
treee40c882c7a6bbcc7ffc5ef0dbea5b1c8e1ffab88 /gnu/packages
parentb37925ecddb4af2965220064a8a603d2fd3a77c5 (diff)
downloadguix-8c56ab99d93c2d37fcc08d3fcff44c64b12ed443.tar.gz
gnu: Add python-benchmark-4dn.
* gnu/packages/python-xyz.scm (python-benchmark-4dn): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e96f4a2d0d..1b6291f12d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17319,6 +17319,27 @@ It is maintained by the Celery project, and used by kombu as a pure python
 alternative when librabbitmq is not available.")
     (license license:lgpl2.1+)))
 
+(define-public python-benchmark-4dn
+  (package
+    (name "python-benchmark-4dn")
+    (version "0.5.23")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "Benchmark-4dn" version))
+              (sha256
+               (base32
+                "0z3vxrkap59sk394ynvp0457mdvb201idcswlrpgjscnrp2h4ypi"))))
+    (properties '(("upstream-name" . "Benchmark-4dn")))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-poetry-core))
+    (home-page "https://github.com/SooLee/Benchmark/")
+    (synopsis "Benchmark functions for CWL workflows")
+    (description
+     "This package provides benchmark functions that return total space, memory,
+CPUs required per given input size, and parameters for CWL workflows.")
+    (license license:expat)))
+
 (define-public python-beniget
   (package
     (name "python-beniget")