summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-28 15:24:40 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-28 15:24:40 +0100
commit8cd115b67eeeb8e62d58b4b5df076528bed58b5c (patch)
treec63a5730e50434343aa69bc918cb28379b4a6fbe /gnu/packages
parent37fdb382dad47149d8f5be41af108478800e9d30 (diff)
downloadguix-8cd115b67eeeb8e62d58b4b5df076528bed58b5c.tar.gz
gnu: emacs-shx: Update to 1.5.0-1.b99d16f.
* gnu/packages/emacs-xyz.scm (emacs-shx): Update to 1.5.0-1.b99d16f.
[arguments]<#:phases>: Appease Checkdoc test.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm53
1 files changed, 31 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59a03f5db1..d042771d77 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6998,31 +6998,40 @@ the speedbar window.")
     (license license:gpl3+)))
 
 (define-public emacs-shx
-  (package
-    (name "emacs-shx")
-    (version "1.5.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/riscy/shx-for-emacs")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32 "1cb5w6p9gnfxgh8qp7yj2f5ibpk1b4b5af3ynldaaj6yfpa8hqzn"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:tests? #t
-       #:test-command
-       '("emacs" "--batch" "--quiet"
-         "--script" "test/script.el")))
-    (home-page "https://github.com/riscy/shx-for-emacs")
-    (synopsis "Extras for the comint-mode shell")
-    (description
-     "This package extends @code{comint-mode}: it parses markup in the output
+  ;; XXX: Some tests fails in the latest stable release.
+  (let ((commit "b99d16f36bc278d668d8428c4bc9af77064c336a")
+        (revision "1"))
+    (package
+      (name "emacs-shx")
+      (version (git-version "1.5.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/riscy/shx-for-emacs")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32 "1wkqnc5n8if8fsh7f3bdr5nzn6dbj1nzdxlmnz8nflmx4g32fp6v"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:tests? #t
+         #:test-command
+         '("emacs" "--batch" "--quiet"
+           "--script" "test/script.el")
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'appease-checkdoc
+             (lambda _
+               (substitute* "shx.el"
+                 (("Toggle shx-mode on") "Toggle `shx-mode' on")))))))
+      (home-page "https://github.com/riscy/shx-for-emacs")
+      (synopsis "Extras for the comint-mode shell")
+      (description
+       "This package extends @code{comint-mode}: it parses markup in the output
 stream, enabling plots and graphics to be embedded, and adds command-line
 functions which plug into Emacs (e.g. use @code{:e <filename>} to edit a
 file).")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-names
   (let ((commit "d8baba5360e5253938a25d3e005455b6d2d86971")