summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-13 21:12:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:51 +0200
commit907ae061700fed724fa8c7e1f3152ea64768e0e9 (patch)
tree8d01abc6cb44cdb10d878c29be881e78fd86fcd3 /gnu/packages
parent59eea190c6e0ec83babe8acfb7c8f527e8ff1772 (diff)
downloadguix-907ae061700fed724fa8c7e1f3152ea64768e0e9.tar.gz
gnu: Add julia-realdot.
* gnu/packages/julia-xyz.scm (julia-realdot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index da18f01b47..5bffb4fa03 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4663,6 +4663,29 @@ by Ranges.")
 type, which make some sacrifices but have better computational performance.")
     (license license:expat)))
 
+(define-public julia-realdot
+  (package
+    (name "julia-realdot")
+    (version "0.1.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaMath/RealDot.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1jr8dq110j8axjfz936b1lqqcnqg3979rfg11w76rq1iz7zgi691"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaMath/RealDot.jl")
+    (synopsis "Compute realdot efficiently")
+    (description "This package only contains and exports a single function
+@code{realdot(x, y)}.  It computes @code{real(LinearAlgebra.dot(x, y))} while
+avoiding computing the imaginary part of @code{LinearAlgebra.dot(x, y)} if
+possible.  The real dot product is useful when one treats complex numbers as
+embedded in a real vector space.")
+    (license license:expat)))
+
 (define-public julia-recipesbase
   (package
     (name "julia-recipesbase")