summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-04-16 16:51:16 -0400
committerLeo Famulari <leo@famulari.name>2021-04-16 16:57:28 -0400
commit92434734c515c5b9fdd55d93eba74a56ad3e01d0 (patch)
tree7db299c111bd48804503a897323c701c8c7d8c04 /gnu/packages
parentd178039a07a33751ac4f7cd582df5ae7349db4fb (diff)
downloadguix-92434734c515c5b9fdd55d93eba74a56ad3e01d0.tar.gz
gnu: libcroco: Absorb grafted replacement.
* gnu/packages/gnome.scm (libcroco)[source]: Use libcroco-CVE-2020-12825.patch.
[replacement]: Remove field.
(libcroco/fixed): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 34f5078581..78a473b348 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3221,10 +3221,10 @@ the GNOME desktop environment.")
               (uri (string-append "mirror://gnome/sources/" name "/"
                                   (version-major+minor version)  "/"
                                   name "-" version ".tar.xz"))
+              (patches (search-patches "libcroco-CVE-2020-12825.patch"))
               (sha256
                (base32
                 "1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))))
-    (replacement libcroco/fixed)
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -3243,21 +3243,6 @@ XML/CSS rendering engine.")
     ;; LGPLv2.1-only.
     (license license:lgpl2.1)))
 
-(define libcroco/fixed
-  (package
-    (inherit libcroco)
-    (name "libcroco")
-    (version "0.6.13")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version)  "/"
-                                  name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))
-              (patches (search-patches "libcroco-CVE-2020-12825.patch"))))))
-
 (define-public libgsf
   (package
     (name "libgsf")