summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-05-21 17:19:51 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 10:31:06 +0200
commit925ef60b669c76f01a07782738b6a923da5fbfd5 (patch)
tree352edc663e53369a3de865e6737ed24e208f674b /gnu/packages
parentafab4dd869c3896aedc2ea50f010f3976db7f21a (diff)
downloadguix-925ef60b669c76f01a07782738b6a923da5fbfd5.tar.gz
gnu: python-plotly: Fix version.
* gnu/packages/graph.scm (python-plotly)[arguments]: In the fix-version phase,
substitute the correct version string.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/graph.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 1091d3d56e..4f44d5b5f4 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2020 Alexander Krotov <krotov@iitp.ru>
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlos@gmx.com>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2023 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
 ;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
@@ -238,11 +238,16 @@ lines.")
             (lambda _
               (setenv "SKIP_NPM" "T")))
           (add-after 'unpack 'fix-version
-            ;; Versioneer is useless when there is no git metadata.
+            ;; TODO: Versioneer in Guix gets its release version from the
+            ;; parent directory, but the plotly package is located inside a
+            ;; depth 3 subdirectory.  Try to use versioneer if possible.
             (lambda _
               (substitute* "packages/python/plotly/setup.py"
                 (("version=versioneer.get_version\\(),")
-                 (format #f "version=~s," #$version)))))
+                 (format #f "version=~s," #$version)))
+              (substitute* "packages/python/plotly/plotly/version.py"
+                (("__version__ = get_versions\\(\\)\\[\"version\"\\]")
+                 (format #f "__version__ = ~s" #$version)))))
           (add-after 'fix-version 'chdir
             (lambda _
               (chdir "packages/python/plotly")))